Geräte führen keine Aktionen aus

Problemstellung

Aktionen für iOS-Geräte stehen auf Ausgeliefert und werden nicht abgearbeitet

Aktionen sind Kommandos, die von Relution auf eingeschriebenen Geräten ausgeführt werden. Diese können entweder implizit über Richtlinienkonfiguration oder explizit durch das Anwenden einer Aktion ausgelöst werden. Die Übersicht aller ausstehenden und ausgeführten Aktionen befindet sich in den Gerätedetails im Tab Aktionen

Mögliche Ursachen

Gerät wurde neu gestartet

  • Das Gerät wurde neu gestartet und bisher noch nicht entsperrt
    • Der digitale Schlüsselbund (Keychain) ist gesperrt, bis ein Gerät nach einem Neustart zum ersten Mal entsperrt wird. In Folge kann das Betriebssystem noch nicht auf gespeicherte Kennwörter zugreifen und sich daher nicht mit einem verschlüsselten WLAN verbinden

Aktion im Kanal “Benutzer”

  • Die Aktion wurde auf dem Benutzer-Kanal versendet und aktuell ist kein Benutzer am Gerät angemeldet

Gerät hat den Verbindunsstatus “Nicht jetzt”

In manchen Fällen beantworten iOS/iPadOS Geräte Kommandos vom MDM Server mit Nicht jetzt. Das ist immer dann der Fall, wenn das Gerät zum aktuellen Zeitpunkt nicht bereit ist mit dem MDM Server zu kommunizieren

Es gibt diverse Gründe die zu einem Nicht jetzt führen können. Die folgende Liste enthält die uns derzeit bekannten Auslöser, die Liste erhebt dabei keinen Anspruch auf Vollständigkeit.

  • Das Gerät ist gesperrt / eine Benutzerinterkation ist erforderlich
    • Einige Kommandos können nicht ausgeführt werden, solange das Gerät gesperrt ist, unter anderem
      • Anwenden bestimmter Restriktionen
      • Konfiguration einer WLAN Verbindung
      • Installation oder Update von Apps
      • Installation von Zertifikate die Benutzerzustimmung benötigen
  • Netzwerk- oder Batteriezustand
    • Das Gerät hat einen zu niedrigen Batteriestand um den Vorgang zu starten
    • Die Netzwerkverbindung des Geräts ist instabil
  • Benutzer verzögert Softwareupdates
    • Ein Update soll eingeplant werden (ScheduleOSUpdate oder InstallLater) und der Anwender verzögert das Update explizit
  • Das Gerät befindet ist noch nicht vollständig eingeschrieben
    • Einige Kommandos können erst ausgeführt werden, nachdem das Gerät die DEP-Einschreibung und/oder den Supervision-Prozess abgeschlossen hat
  • Das Gerät ist anderweitig beschäftigt
    • Das System führt aktuell einen kritischen Task aus (Update, iCloud Backup oder Restore)

Lösung

  • Entsperren Sie die Geräte und stellen Sie eine stabile WLAN-Verbindung her
  • Sofern notwendig melden Sie sich mit einem Benutzer am Gerät an
  • Bestätigen Sie potentielle Dialoge vom Betriebssystem
  • Laden Sie das Gerät bei Bedarf vorher auf

Weitere Informationen

Der Nicht jetzt Status ist reguläres Verhalten von iOS/iPadOS und nicht Relution-spezifisch

Seit Version 5.8.1 ist Relution in der Lage Nicht jetzt Antworten von Geräten zu verstehen. Beantwortet ein Gerät ein Kommando mit Nicht jetzt stellt Relution den Verbindunsstatus für das jeweilige Gerät im Inventar entsprechend um. Um Geräte in diesem Zustand wieder dazu zu bringen mit dem MDM zu kommunizieren müssen diese in aller Regel entsperrt und zum Beispiel ausstehende Betriebssystemupdates ausgeführt werden.

Einige Aktionen, wie etwa Verlorener Modus (Lost Mode) und Passwort zurücksetzen, werden vom Gerät priorisiert behandelt und auch in diesem Zustand entgegengenommen. Seit Version 5.9 behandelt Relution diese Aktionen ebenfalls priorisiert und überspringt alle derzeit ausstehenden Aktionen. Damit ist sichergestellt, dass Geräte die vorherige Aktionen mit Nicht jetzt beantwortet haben trotzdem in den Lost Mode versetzt werden können oder das ein vergessenes Kennwort dennoch geändert werden kann.