Devices are not performing actions

Problem

Actions for iOS devices are pending and not being processed.

Actions are executed operations and changes made via Relution on enrolled devices. They can be triggered either by a policy configuration or by an action. The overview of all actions is located in the device details under the Actions tab.

Cause

iOS devices are unable to accept and execute actions. They accumulate in the action queue. This can be due to several reasons:

  • The devices have an unlock code. This prevents some actions from being processed. This includes, for example, the application of restrictions. This results in the display Not now.

  • The device has been rebooted and not unlocked. Then the digital keychain is locked. Consequently, the devices cannot connect to an encrypted WiFi and thus cannot receive and process actions.

This is a limitation by Apple and occurs regardless of Relution.

Solution

Unlock the devices and ensure a WiFi connection to resolve the Not Now status.

Not Now

More information

The Not Now status was introduced with Relution 5.8.1. Since Relution 5.9, the actions Lost Mode and Reset Password trigger a skip of pending actions. Once an Internet connection is established, these two actions are prioritized and all other pending actions are skipped.