Devices are not performing actions
Problem
Actions for iOS devices are shown as Delivered and never complete.
Actions are commands that Relution executes on enrolled devices. These can be triggered either implicitly by a policy configuration or explicitly by applying an action. An overview of all pending and executed actions can be found in device details under the
Actionstab.
Possible causes
Device has been restarted
- The device has been restarted and has not yet been unlocked
- The digital keychain is locked until a device is unlocked for the first time after a restart. As a result, the operating system cannot yet access stored passwords and therefore cannot connect to an encrypted Wi-Fi network
Action in the “User” channel
- The action was sent on the user-channel and no user is currently signed in on the device
Device has connection status “Not now”
In some cases, iOS/iPadOS devices respond to commands from the MDM server with Not now. This always happens when the device is not ready to communicate with the MDM server at that moment
There are various reasons that can lead to a Not now response. The following list contains possible triggers currently known to us, but the list is not exhaustive.
- The device is locked / user interaction is required
- Some commands cannot be executed while the device is locked, including
- Applying certain restrictions
- Configuring a Wi-Fi connection
- Installing or updating apps
- Installing certificates that require user consent
- Some commands cannot be executed while the device is locked, including
- Network or battery status
- The device has too low a battery level to start the process
- The device’s network connection is unstable
- User delays software updates
- An update is to be scheduled (
ScheduleOSUpdateorInstallLater) and the user explicitly delays the update
- An update is to be scheduled (
- The device is not yet fully enrolled
- Some commands can only be executed after the device has completed the DEP enrollment and/or supervision process
- The device is otherwise busy
- The system is currently performing a critical task (Update, iCloud backup, or restore)
Solution
- Unlock the devices and establish a stable Wi-Fi connection
- If necessary, log in to the device with a user account
- Confirm any dialog boxes from the operating system
- Charge the device beforehand if necessary
Further information
The “Not Now” status is normal behavior of iOS/iPadOS and is not specific to Relution
Since version 5.8.1, Relution is able to understand Not Now responses from devices. If a device responds to a command with Not now Relution changes the connection status for that device in the inventory accordingly. To get devices in this state to communicate with the MDM again, they usually need to be unlocked and any pending operating system updates need to be performed, for example.
Some actions, such as Lost Mode and Reset Password are prioritized by the device and accepted even in this state. Since version 5.9, Relution also treats these actions as a priority and skips all currently pending actions. This ensures that devices that previously responded to actions with Not now can still be put into Lost Mode or that a forgotten password can still be changed.